1. About
  2. Features
  3. Explore

About two days ago, I started seeing that my hotend was heating up erratically. I first noticed this while printing a part in PETG and the temp jumped to 260 °C. I shut down the printer at that time and first started checking the hardware. I noticed that the E3D V6 thermistor had been tightened too much. I disassembled the entire hotend, cleaned everything and then reassembled everything. I thought to retune the hotend and when I tried tuning it at 240 °C.

This is where the strange behavior occurs. The hotend steadily climbed up till about 200 °C. After that it just went nuts. I started seeing unreal temps such as 646 °C and such. At this point I thought the MEGA might be at fault. I replaced it and the hotend (an E3D V6 clone). This had the screw on glass thermistor. Again the same erratic behavior and unreal temp readings.

What could be wrong here? What am I missing? Can this be the heater cartridge?

1 Answer 1

This can come from several sources:

Hardware

The thermistor or its connections might be damaged, and the fault is only observable when the hotend is hot or moved to a certain area. Start by checking the wiring! You may be able to repair a bad connection easily, but depending what was broken, you may need to replace something. In some cases squishing a thermistor cartridge too much can destroy the internals, so a replacement is needed.

A mainboard failure is more likely to just show a static temperature, and a heater failure would show as maybe not getting past a certain point.

Firmware

If it had not worked before or you changed the firmware, the firmware should also be a suspect. The firmware can 'fail' when using the wrong thermistor type/table which can result in a very big offset or bad slope, resulting in wrong or unaccurate readings.


Other Answers